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1 Before Reading This Document

It is assumed that the reader is familiar with the V+ visual programming system, in particular the use of I/O devices and ports.  If not, the reader should become familiar with V+ by downloading the V+ Programming System user manual from the Downloads area of our web site: http://www.simphonics.com/support/downloads/docs/.  Also, the user must be familiar with the SMx Audio System, and the associated I/O devices that are part of the SMx Audio System.  Read the document “SMXMIX - Mixin it up with SMx.doc” located at: http://www.simphonics.com/support/downloads/docs/ this file explains the layout of the mixer and operation of the SMx in detail.

1.1 Files Needed for this Tutorial

All of the files needed for this tutorial are located at: http://www.simphonics.com/library/VPLusSamples/SMx/SMx%20Testing%20Designs/
If you don’t find these files at this exact location, be sure to check the top level folder for SMx testing files, since this information is being updated regularly and the file folder names may have changed to reflect new changes etc.

2 Introduction

This document illustrates how to test the 16 different SMx channels and make sure all channels are coming out of the right place and being mixed properly. The user is shown how to setup the SMx to play 16 different FXDirect (WAV) players out to 16 discrete channels.  While any WAV file could be used for this purpose, this files used in this design example are voice WAV files that actually announce the channel.

Remember that multiple players may be assigned to a single channel, although this example uses a single player per channel.  Most actual V+ sound modeling applications use many player per channel.

This example can also be used as a daily readiness test design for testing the output channels of the SMx system.  Using voice files for testing does not actually check the amplitude limits, etc., of the SMx, and therefore, sine waves should be used for testing SMx production units.

The diagram below further illustrates the process as a wave-file is generated, mixed by the Windows Audio mixer, then applied to the SMx mixer.
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3 V+ Designs

There are 3 V+ designs needed for this tutorial. Each worksheet performs a specific independent function.  The file “SMx Output Channel Test.des” generates 16 discrete waveforms from wavefiles.  The Windows operating system exposes a basic mixer for setting the output volume which is controlled by the file “WAM settings 16 Channel Test.des”.  Finally the V+ design file “SMx Mixer WO to AO setup.des” for routing these waveforms to the final outputs on the SMx system.  These files will be described in more detail later in this document. 
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3.1 Windows Audio Mixer Settings for 16 Channel SMx Design

The Windows Audio Mixer I/O Device is a generic device for use with any sound card in the PC with a Windows driver. The SMx system exposes a set of controls that are shown in the dialog box below.
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Figure 1 - SMx Line Volume Dialog Box

By using the Windows Audio Mixer Device for V+, V+ can see these controls as ports. Since anyone can come along and adjust these controls in Windows, V+ can override these settings in real-time, allowing V+ control over the WAV output volume, balance, etc.  Therefore, no matter what folks may do with these controls in Windows for the SMx, V+ can override the volume settings for the WAV output.
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Figure 2 - Windows Audio Mixer Settings V+ Design

3.2 SMx Output Channel Test V+ Design

Shown below is the SMx Output Channel test V+ worksheet. This worksheet generates 16 discrete waveforms.  Each player object shown on the worksheet below, is associated with a wave-file, and can control the volume, and pitch (frequency) of each waveform as well as an enable and balance control. 
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Figure 3 - SMx Output Channel Test V+ Design

3.3 SMx Mixer Setup for WAV Out to Analog Out V+ Design

Shown below is the SMx Mixer Setup for Wav out to Analog out V+ worksheet.  The file contains ports that control mixer settings on the SMx mixer.  The constants driving these ports enable the mixer settings so that the WO (Wave Out) signals are routed to respective AO (Analog Out) of the SMx system hardware.

Note that not only are the channels routed to outputs, but there are master volumes present on the outputs of the SMx mixer that are being enabled also.  All constants are 1.0.  Ports that are not on the worksheet but part of the SMx mixer, are set to zero by the I/O device.

[image: image8.jpg]HEE
EllE
:
BEEE
BEEE
ElElH
Tit o

|

=
ﬁ
H
H

SMx Mixer Setup for WAV out to ANALOG out

Q
E
H
5
3
2

— i

e

B
=

i

:

|
|

=4

BT .

"

Channels 8 -
EED
o1
o
a7z
R
o
o
o

16
.
e
e
et
.
o
i

i

Masters 1 -8

|

e

=
!
£
H

|

e

!
£
=

o

=)

EEE
EElH

|
ﬁ

Masters 8 - 1

5

i
i
ot
e
et
i
i

i




Figure 4 - SMx Mixer Setup for WAV Out to Analog Out V+ Design

4 Getting Started

4.1 Applying/Removing Power

AC power should be applied to each of the SMx components simultaneously or within a few seconds of each other. If power is removed from one of the external chassis’ while the SMx CPU system is running, the system will have to be restarted.

4.1.1 Powering Up the System

1. Turn the SMx breakout box and expansion box power on first. 

2. Then apply power to the computer chassis.

Note: The SMx system does not work properly when it is not powered up in the correct sequence. Turn the SMx breakout box and expansion box power on first. Then apply power to the computer chassis.

4.1.2 Powering Down the System

When powering off the SMx system, shut down the SMx system CPU first, using the shutdown feature of the operating system, and then removing power to the CPU first, and then to the external SMx chassis.
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Figure 5 - SMx Breakout Box & Expansion Box
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Figure 6 - Chassis

5 Loading Files

Before using this tutorial you must download WAV files and V+ design files to your computer. There are 16 wav files (one for each channel) and 3 V+ designs. These files are downloaded from our download center at our website: http://www.simphonics.com/library/VPLusSamples/SMx/. 

Table 1 - Files Needed for SMx Channel Test

	Wave files
	V+ design files
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5.1 Loading Wave Files

To load the WAV files:

1. Create a folder in the root directory called “WAVEFILES.” 
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2. Download all wave files and save in the C:\WAVEFILES directory.

Tip: To download WAV files, right click on the WAV link and select Save Target As…. Then save in the WAVEFILES folder you created above in step 1.

5.2 Loading V+ Design Files

To load the V+ files:

1. Download all the V+ design files listed below and save in your 

C:\Program Files\VPLus\designs directory: 

SMx Mixer WO to AO setup.des 

SMx Output Channel Test.des 

WAM settings 16 chan SMx.des 

6 Setting up V+

6.1 Configuration

The two I/O devices listed below must be loaded and configured in order to run this test. I/O devices are configured in the V+ Run-Time System (Platform Shell).

	2 I/O Devices Needed for this Tutorial

	SMx Audio System

	Windows Audio Mixer


Both of these devices are automatically installed with every SMx system. However they can also be downloaded from our software download center at SimPhonics web site: http://www.simphonics.com/support/downloads/software/ 
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Figure 7 - V+ Platform Configuration dialog box

6.1.1 Opening the V+ Run Time System (Platform Shell)

	Use one of the following methods to launch the Run-Time System:
· Select the executable file "vplpltsh.exe" from the "V+" folder in your Windows Explorer.

· Select Programs > V+ > V+ Tools > V+ Run-Time System from the Start menu.


Tip: The Platform Shell can also be launched by first starting the V+ Development System. The Platform Shell automatically loads in a separate window behind the V+ Development System.

6.1.2 Configuring the Windows Audio Mixer Driver

One of the I/O devices needed for this test, is the Windows Audio Mixer Device for V+. This device is installed with the SMx, or may be downloaded separately.

To configure the Windows Audio Mixer I/O device:
1. Select Configure from the V+ Run Time System menu. This opens the Platform Configure dialog box.

2. Select the I/O Drivers tab from the Platform Configure dialog box.

3. *Double click the icon next to the Windows Audio Mixer Device.

4. Select OK to close the Platform Configure dialog box.

6.1.3 Configuring the SMx Audio System Driver

The SMx Audio System driver for V+ exposes a number of devices that are used to control and monitor the SMx hardware and software.

To configure the SMx I/O device:
1. Select Configure from the V+ Run Time System menu. This opens the Platform Configure dialog box.

2. Select the I/O tab from the Platform Configure dialog box.

3. *Double click the icon next to the SMX Audio System I/O device.

4. Select OK to close the Platform Configure dialog box.

*Note: Below is an example of how the I/O devices appear when they are configured.
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Figure 8 - Platform Configuration Dialog Box

6.2 Loading V+ Design Files

To load the V+ design files:

1. Use any of the following methods to open the V+ Visual Programming System:

· Select Tools > Launch V+ from the V+ Run-Time System.

· Select [image: image16.png]


 from the V+ Run-Time System shortcut menu.

· Select the executable file "vplus.exe" from the "V+" folder in your Windows Explorer.

· Select Programs > V+ > V+ Tools > V+ Development System from the Start menu.

2. Select Open from the File menu.

3. Browse for and open each of the 3 V+ design files listed below.
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4. Once all the V+ design files are open, select Start from the Platform menu or select [image: image18.png]


 from the shortcut bar. The following message appears:
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Figure 9 - Executing Worksheet(s)

5. Select the Yes button to execute all worksheets.

Note: The status box, located in the lower left corner of the V+ Visual Programming System indicates if the designs have been successfully launched.  Once a design is executing, the Messages Area, located in the lower left corner, informs you that your design is running and a green light appears on the V+ Status Bar. Also, a green dashed line appears around all executing objects. Below are graphics showing an object executing and one that is not executing.

	Executing...
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	Not executing...
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7 Testing the Channels

Once the WAV files and V+ design files are loaded and V+ is configured and running, the channels can be tested. Test each output with your multimedia headset.
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Figure 10 - SMx Breakout Box and Expansion Box – Rear View

To test the channels:

1. Plug the multimedia headset into the Channel 1 output
2. Listen for the test recording. Repeat steps 1 and 2 for all 16 channels.

8 Troubleshooting

	Problem
	Solution

	No sound is heard.
	Check the WAV Files Directory

Make sure the WAV files are stored in the correct directory. If the folder is not named correctly or is in the wrong location V+ will not be able to locate the files. The folder must be placed on the root directory, C:\, and named “wavefiles.”
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	Windows is not recognizing the SMx driver.
	Restart the System
The SMx system does not work properly when it is not powered up in the correct sequence. Turn the SMx breakout box and expansion box power on first. Then apply power to the chassis. Also, if power is removed from one of the external chassis’ while the SMx CPU system is running, the system will have to be restarted. See Applying/Removing Power for more information.


9 Appendix

9.1 Figures

7Figure 1 - SMx Line Volume Dialog Box


7Figure 2 - Windows Audio Mixer Settings V+ Design


8Figure 3 - SMx Output Channel Test V+ Design


9Figure 4 - SMx Breakout Box & Expansion Box


9Figure 5 - Chassis


11Figure 6 - V+ Platform Configuration dialog box


12Figure 7 - Platform Configuration Dialog Box


13Figure 8 - Executing Worksheet(s)


14Figure 9 - SMx Breakout Box and Expansion Box – Rear View




9.2 Tables

7Table 1 - Files Needed for SMx Channel Test
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This I/O device is configured and ready for use.





Note: The folder must be placed on the root directory, C:\, and named “wavefiles” or V+ will not be able to locate the files.
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