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INTRODUCTION 

Introducing V+ 

V+, pronounced "V - Plus", is a completely new way of programming systems that interact with real-world 
signals in real-time.   V+ was created for system engineers and other computer professionals who need 
tools to transform their ideas into reality without the headaches of code.  In fact, code is just that, code, 
something that is difficult to read and understand unless you are skilled in the art.  

One of the paramount goals in the design of V+ was to create an extensible language.  That is, a 
language that can be easily adapted and changed to match changing operating systems, and 
accommodate new hardware.  If there is a universal constant in the computing world, it is change. 

V+ is finding more and more uses in the simulation and training industry.  From simple low fidelity 
systems, to full flight simulators, V+ is being used for I/O, audio, and DIS radio applications.   Also, third 
parties are now beginning to develop objects and I/O devices that extend the V+ inventory of resources. 

What is a Visual Programming Language? 

A small but growing community of Visual Programming Language (VPL) people exists today. They have 
yet to accept a formal definition of a VPL. SimPhonics' own simplified contribution is a derivation of 
Webster's definition for the three words in VPL.  

Webster Says:  

Visual: Something (as a picture, chart, or film) that appeals to the sight and is used for 
illustration, demonstration, or promotion.  

Programming: To work out a sequence of operations to be performed by a mechanism.  

Language: The words, their pronunciation, and the methods of combining them used an 
understood by an considerable community. 

Refine this and we have:  

"Using Images for illustration of operations to be performed by a mechanism and the methods of 

combining them used and understood by a considerable community".  

 

This is a highly simplified but practical definition. Execution is encapsulated in the sequence "of 
operations to be performed by a mechanism". The word "mechanism" is used instead of “computer” since 
the execution may be carried out by something other than a computer.  

What is V+? 

Traditionally, computers are programmed using text-based languages such as C, C++, Visual Basic, etc. 
Text based programming requires a working knowledge of a programming language. Writing the code for 
the simple mathematical equation "1+1=2" requires knowledge of a programming language. V+ uses 
graphic images to perform this same operation.  
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V+ is a Visual Programming System based on a Visual Programming Language (VPL), that replaces 
conventional textual programming languages such as C++, FORTRAN, PASCAL, etc. in some 
applications. Primarily, a VPL differs from a text-based language in that images replace the text, providing 
a more natural programming paradigm.  

V+ is called a Visual Programming System since V+ is much more than just a VPL. Other features are 
provided automatically with V+ that would require several separate tools and steps in a text-based 
language, in order to arrive at the finished product. 

Why use V+? 

V+ is a natural choice for systems that input real-time data, process this data, and output the data in real-
time under the control of a host computer. These systems are generally signal processing, or control 
systems, and are naturally conceived as a block diagram of processing elements. Of course, V+ is not 
restricted for use with real-time systems. 

 

    

V+ applications can vary widely from Control Systems, Digital Audio Systems, Custom Interfaces, 
Educational, etc. 
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THE BASICS 

The Basic Components 

The V+ system is divided into two separate executables, a development system and a Run-time 
system.  The development system is used to create and edit designs, while the platform shell is used to 
configure the system and to execute the designs created in the editor. 

 

Figure 1 - V+ Development and Run-time Systems 

Using the Visual Editor, a design is drawn on a worksheet by dragging objects from a list of available 
objects and dropping them in place. These objects are then connected via nets to other objects or ports. 
Ports are grouped into I/O Devices which are Input/Output objects connecting the design to real-world 
signals, such as RS-232, Ethernet, etc.  Designs may consist of one or more worksheets that can be 
combined into a project.  The design can then be executed on the Run-Time System. 
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V+ Designs 

Simple Designs 
Before getting into the details, let's look at some simple V+ designs. The simplest possible V+ design is a 
constant connected to a no-connection.  While this does nothing for us, it shows how V+ is a data-flow 
syntax.  An object on the left sends data to an object on the right. 

 

 

Figure 2 - Basic V+ Designs 

Next, let's use an I/O Device and some simple math. Two input variables from a network are added 
together to produce another result that is then sent out over the network.  A very expensive networked 
adding machine. 

Next, a multiply, and a little more math. 

 

 

Figure 3 - Basic V+ Designs – Simple Math 
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Slightly More Advanced  
One of the important features of V+ is feedback.   As the design below illustrates, the data from the input 
is multiplied by itself and then applied to the output.  The next figure shows the same design except with 
the data for the multiply being fed back to the input.  The result is the same, except that the data coming 
back to the multiply is delayed by one processing frame.  This concept is very useful for digital signal 
processing applications. 

 

 

Figure 4 - Basic V+ Designs with Feedback 

The next design is a simple first order filter.  K1 and K2 are in the constants (k) shown.  The delay 
element is f(n-1) feedback path through the multiply. 

 

Figure 5 - Simple First Order Filter 
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A more complex design 

 

Figure 6 - Complex V+ Design 
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About Real-Time Frame Rate Processing  

Real-time systems generally process data on an iterative basis.  That is, the computer models the system 
in real-time by inputting data from a device, processing the data, and then outputting the data to another 
device periodically.  This period is called a frame, and the rate at which this frame is processed is called 
the frame rate, or iteration rate.  V+ defaults to use a frame rate of 30 Hz.   V+ can be configured to 
operate at rates up to 600 hertz. 

When a V+ design is executed, the objects and I/O devices are sorted according to input devices, objects, 
and output devices as shown below. The order of the objects can be manually adjusted by the user. 

 

Figure 7 - Execution Sequence 

 

Figure 8 - Processing Load 

V+ calculates the spare time per frame so that the user is aware of the processing load. 
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Navigating V+ 

V+ provides right-click menu support for doing the most common tasks. The menu options that are 
displayed are different in each component. 

V+ Run Time System Toolbar 

 

Figure 9 - V+ Run Time System Toolbar 
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Visual Programming System Toolbars 
Below are the V+ toolbars with a description of the actions they initiate. 

 

 

Figure 10 - V+ Development System Toolbars 
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Need Some Help? 

There are two V+ Help Systems available for assistance:  

 On-line V+ User Manual 

 Object Help System 

These help systems are intended to give users key information concerning the use and operation of V+.  

On-line V+ User's Manual 
The on-line user's manual contains information about how to operate V+.  

 

Figure 11 - V+ Online Help System 

Use either of the following methods to access the online manual: 

 Select Help > User Manual. 

 Select the "F1" key. 

Note: It is recommended that you view the User's Manual with your browser window expanded due to the 
size of some of the screen shots. In addition, if you are viewing this User's Manual on the internet, it is 
recommended that you use Internet Explorer 4.0 or greater. 
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Object Help System  

This help system is used to familiarize users with the selection and use of V+ objects. This help system 
offers information on individual objects, the functions of the input and output pins and Static Data.   

 

Figure 12 - Object Help System 
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STARTUP 

System Requirements 

Installing V+ is simple, and requires only a few steps.  V+ is shipped CD-ROM or can be downloaded 
from the Internet. 

Part Number  Description 
VPLDEV-X86 V+ Development System for X86 Based Systems 

VPLRTL-X86 V+ Run-Time System See I/O Device List for I/O Devices that are Included with the Run-Time 
System 

  
Make sure your computer meets the following minimum system requirements: 

To properly run the software you need: 

Processor 
Intel Pentium 4 Processor 
512K L2 Advanced Transfer Cache 
533MHz System Bus 

Motherboard 
ATX 533MHz-capable Socket 478 DDR Motherboard 
Native USB Support 
ACPI/WOL Compatible 

Memory 
512MB DDR (Double Data Rate) SDRAM 
PC2100 266MHz or Faster 

Hard Drive 
Ultra ATA/100 7200RPM High Performance Hard Drive 
10GB or Larger 

Communication 
One or more 10/100Mbps Ethernet Adapters 
ACPI/WOL Compliant 

Video 
AGP 2X, 32MB or greater with OpenGL driver support 

CD-ROM 
48x or faster CD-ROM Drive   

Floppy Drive 
1.44MB 3.5” Floppy Drive 

Power Supply 
ATX 2.03(or above)-compliant Power Supply 
300W or greater with 12V (Pentium 4) power connector 

Operating System 
Microsoft Windows 2000 or WindowsXP Professional 

Note:  For multichannel sounds cards, DirectX 7.0 may cause problems.  Use Direct 6.0 until DirectX 8.0 
or greater is available. You may need your original Windows operating system disk for the DirectX 
installation that follows the installation. 
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Operating System Compatibilities 

Different V+ builds are compatible with different operating systems. Use the following instructions to 
determine which build is installed on your computer. See our website for a list of operating system 
compatibilities. http://www.simphonics.com/products/software/compatibility.asp  

Determining Which V+ Version is Installed 

To determine your V+ Version: 
1. Select Help > About V+ from the V+ Visual Programming System. This opens the About 

VPLus dialog box.  Note: The last 3 numbers of the version number determine which V+ build is 
installed. 

Do not use the V+ Run-time System to determine which version you are using. The version number is 
displayed on your screen. 

Release Notes:    
 For V+ Build 205 and later, Windows 95, Windows 98, Windows 98 Second Edition, and Windows 

NT are no longer supported as operating systems for new SimPhonics products. New products 

are now shipping with Windows 2000 or Windows XP. SimPhonics maintains older versions of all 

software. If you need an older version that may is compatible with an earlier operating system, 
contact SimPhonics.  

 If you are using Windows98SE or earlier and downloading V+ Run-Time System or V+ 

Development System you must install the latest version of DirectX. DirectX is available for free 

from Microsoft.  

 All V+ designs are completely portable across all platforms. If a V+ application was developed 

using windows 95 or 98, it will still work on Windows XP without modification.  

 When using Windows NT with V+, ensure you are using service pack 4 or greater.  

 Comprehensive release notes are available in the c:\program files\vplus\help folder. 

Warning: You will loose any I/O devices if you uninstall V+ unless you follow the steps provided in the 
“Upgrading to a Newer Version of V+” section.  

Installing the Software 

Before installation, login as the administrator on the system. 
 
There are 2 ways to install V+ on your computer 

 Install V+ from the CD 

 Download V+ from SimPhonics' V+ Download Page. 

To Install V+ from the CD: 
1.   Insert the media and execute the setup program on the disk. 

2.   The program's installer will walk you through the process off setting up the software. Follow the 
instructions and remove the CD when completed. 

Notes:  Be sure to use the default settings that the setup system requests to use. 

http://www.simphonics.com/products/software/compatibility.asp
http://www.simphonics.com/about/contact/
http://www.microsoft.com/windows/directx/downloads/drx81.asp
http://www.microsoft.com/windows/directx/downloads/drx81.asp
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Upgrading V+ 

Always uninstall V+ before installing a new version. 

Maintaining Registry Settings 
When upgrading or installing a newer version of V+ the I/O device drivers will be removed also.  To avoid 
the process of reloading the device drivers, there is simple procedure to save  (i.e. Export) your registry 
settings and then recover (i.e.  Import) them after your V+ upgrade. 

This process takes only a few minutes and allows you to get back to your application or design efforts!  
The four steps of the process are detailed below. 

Note: The following steps are only necessary if you want to keep your old settings and I/O devices. 

1) Export V+ Registry Settings 

a. Select Run from the Start menu. 

b. Enter  regedit to open the  Registry Editor dialog box. 

c. Browse to HKEY_LOCAL_MACHINE\SOFTWARE\. 

d. Highlight the SimPhonics folder. 

e. Select  Export Registry File from the Registry menu. 

f. Save file as  vplusreg on your desktop. 

g. Close Registry Editor dialog box. 

2) Uninstall V+ 

a. Select Start > Settings > Control Panel. 

b. Uninstall old version of V+ via Add or Remove Programs selection. 

3) Reinstall V+ 

a. Reinstall new version of V+ either via CD or Web download. 

4)  Import Registry Settings 

a. Double click the  vplusreg file on your desktop. 

b. Select Yes to add the information to the registry. 

c. Select OK. 

About the V+ Run-time System 

The V+ Run-time System is a configuration and execution tool for V+ designs. It is also the platform on 
which V+ designs are executed (ran). To understand how this system works, you must first understand 
the basics behind the V+ Development System.  V+ takes related design files (filename.des) and 
incorporates them into a project file (projectname.vpj). Then, an executable .vne file is created allowing 
the visual program to be executed in the Run-time System.  The Development System is used to develop 
V+ applications and is not needed to run or configure the design. 

V+ must be fully configured when editing designs since all execution and resource aspects of V+ are 
contained in the Run-Time System.  However, this system can function as a stand-alone platform during 
Run-Time. 

The platform shell informs the editor of the object inventory.  That is, the platform shell contains the actual 
objects that V+ can use. 
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Starting the Run-time System 

The Run-time System must be started and configured (see Configuring the Run-time System) before a V+ 
design or project can be created. 

 

Figure 13 - Run-time System 

Note:  Before the Run-time System is launched, or when it is closed, the menus and toolbar buttons in 
the V+ Development System are disabled, not allowing V+ designs to be edited. 

Use one of the following methods to launch the Run-time System: 

 Select the executable file "vplpltsh.exe" from the "VPLus" folder in your Windows Explorer.  

 Select Programs > VPLus > V+ Run-Time System from the Start Menu.  

Tip: The Platform Shell can also be launched by first starting the V+ Development System. The Platform 

Shell automatically loads in a separate window behind the Development System. 

Configuration 

Configuring the Run-time System 
Once the V+ Run-time System is started, it must be configured for use.  The Platform Configure dialog 
box is used to configure the following: 

 I/O Devices 

 Execution Speed 

 Sound Card Configuration 

 Third Party Devices 

Tip:   If you need help configuring an I/O Device, highlight the device and select the Help button to 

activate the I/O Device Help System. 
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Figure 14 - Platform Configure Dialog Box 

To open the Platform Configure dialog box: 
1.   Select Configure from the V+ Run Time System menu. This opens the Platform Configure dialog 

box. 
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About IO Devices 

 

Loading/Enabling I/O Devices 
The I/O Drivers property page allows the user to load/enable the necessary I/O devices. If the device you 
want to configure is not found, it needs to be installed on your computer. Go to 
http://www.simphonics.com/supp/downloads/default.asp to download additional V+ I/O devices. 

Auto Load Feature 
Starting with V+ Build 230, I/O devices can auto load themselves if a certain registry key is present for the 
I/O device. This feature is currently available for the SMx Audio System Software.  

When using V+ Version 1.0, Build 230 or later and SMx Audio System Software Version 

2.0, Build 106 or later, the SMx driver is automatically loaded and enabled when the run-
time system is started. 

http://www.simphonics.com/supp/downloads/default.asp
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To enable/load I/O devices: 
1.   Select Configure from the V+ Run Time System menu. This opens the Platform Configure dialog 

box. 

2.   Select the I/O Drivers tab from the Platform Configure dialog box. 

3.   Double click the icon next to the desired I/O device. The device is enabled when there is no longer a 
 

 over the device. 

4.   Select OK. 

Note:  If you need help configuring an I/O Device, highlight the device and select the Help button to 
activate the I/O Device Help System. 

Setting the Execution Rate 
The Execution property page of the Platform Configure dialog box is used to set the execution rate for 
the selected platform.  The execution rate is shown in milliseconds.  For example, an execution rate of 25 
means the platform will be executed every 25 milliseconds, or 40 times per second. 

To set the execution rate: 
1.   Select Configure from the V+ Run Time System menu. This opens the Platform Configure dialog 

box. 

2.   Select the Execution tab from the Platform Configure dialog box. 

 

 

Figure 15 - Setting the Execution Rate 

3.   Enter the desired rate in the Execution Rate text box. 

4.   Select Apply to apply the rate. 

5.   Select OK. 

Note:  The default execution rate is 25ms. 

Configuring Audio Cards 
The Sound Device Configuration tab of the Platform Configure dialog box is used to choose input and 
output channels and to set the channel properties. 
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1.   Select Configure from the V+ Run Time System menu. This opens the Platform Configure dialog 
box. 

2.   Use the Up and Down buttons to locate the correct output and input sound devices. 

3.   Select the correct devices.  The choices are highlighted when the selection is made. 

 

Figure 16 - Choosing the Sound Device 

Configuring Channels for DIS/HLA Communications 
Be sure to select 16 Bits/Sample when using a channel for DIS/HLA communications. The run-time 
system will not start when 8 Bits/Sample is selected, and the following text appears in the message box: 

"Channel “n” bits/sample must be at least 16. Change the setting and restart.” 

Where “n” is the channel number. 

V+ is not designed to run using 8 Bits/Sample because of unacceptably poor performance for 
communications systems while using this setting. 

 

Figure 17 - Sound Device Properties 
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VISUAL EDITOR 

About the Visual Editor 

The Visual Editor is a development system. It is used to create and edit V+ designs.  

Starting the Visual Editor 

Use any of the following methods to launch V+ Development System: 

 Select the  button from the V+ Run Time System toolbar. 

 Select the executable file V+.exe from the Windows Explorer.  

 Select Programs > VPLus > V+ Editor from the Start menu. 

Note:  Launching the visual editor (V+ Development System) opens the Platform Shell window.  The 
Platform Shell must be configured before a design can be edited in the Development System.  See 
Configuring the Platform Shell for help. 
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PROJECTS 

About V+ Projects 

Projects allow multiple worksheets to be contained in one design by encapsulating these related 
worksheets into a single project file (projectname.vpj). During run-time, all worksheets contained in a 
project execute simultaneously. This allows the user to create and test different portions of a design 
independently. Worksheets can be created as stand-alone designs or inserted into a project with other 
worksheets. See About Design Execution for more information concerning the execution of V+ projects. 

Starting New Projects 

In the past, V+ designs have simply been saved as design files (filename.des). Now, you can encapsulate 
multiple related design files into one Project File (projectname.vpj). This creates a manageable, 
hierarchical collection of designs, which can be displayed and viewed in the Project Manager Window. 
The Project Manager consists of a tree directory in which the project hierarchy is shown. 

To start a new project: 
1.   Select File > New > Project from the V+ Visual Programming System menu. This activates the 

Project Manager Window button - . 

Opening Projects 

Existing project files (*.vpj files) are opened from the V+ Editor. 

To open an existing project: 
1.   Select Project > Open Project. 

2.   Locate and open the project. 

Note:  Before opening and executing a project, make sure the correct Run Time System .vne file is open. 
To do this, go to the V+ Run Time System (Platform Shell) and select File > Open. Then browse for and 
open the .vne file. 

Managing Projects 

Projects are viewed and maintained in the Project Manager window. The worksheets contained in the 
project are displayed in a tree directory. See Inserting Worksheets for instructions on adding files to 
projects. 

To display the project manager window: 

1.   Select the  button from the toolbar. 

2.   To access a file within a project, double-click the filename in the project list. An open design file is 
shown in the Project Manager with the V+ icon while a closed design file is shown as a closed folder. 
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Figure 18 - Project Manager Dialog Box 

Inserting Worksheets 

Existing files, or worksheets, can be inserted in the Project Manager at any time. 

To insert a file: 
1. Open the project. See Opening Projects for instructions. 

2. Select the  button to display the Project Manger window. 

3. Right click inside the Project Manager window 

4. Select Insert Files into Project from the pop-up menu. 

5. Locate and open the desired file. This inserts the file in the project and displays it in the Project 
Manager window. 

Adding Worksheets (Designs) to Existing Projects  

V+ is divided into a development environment, V+ Visual Programming System, and run-time 
environment, V+ Run Time System. Using the development environment, related design files 
(filename.des) are incorporated into a project file (projectname.vpj). Then, an executable .vne file is 
created allowing the visual program to be executed in the run-time environment.  When a new worksheet 
is added to a project, there are a few steps you must follow to successfully make this change part of the 
run-time system and executable file. 

1. Using the V+ Visual Programming System, open the V+ project (projectname.vpj). 

2. Stop the V+ Run Time System, if it's running. 

3. Using the V+ Visual Programming System, create a new worksheet, or insert an existing 
worksheet into your project. 

4. Select Start from the Platform menu (or select  from the shortcut bar) to execute your 
project. 

5. After verifying the project is successfully running, select from the shortcut bar to stop the 
project. 
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6. Save your project. Note: Once your project has been successfully executed and saved, you must 
also save the new executable/platform configuration file. 

7. Go to the V+ Run Time System window. 

8. Select Save from the File menu (or select from the shortcut menu) to save the current 
platform configuration (.vne file). 

Removing Worksheets 

Files, or worksheets, can be removed from a project using the Project Manager. 

To remove a file: 
1.   Open the project. See Opening Projects for help. 

2.   Select the  button to display the Project Manger window. 

3.   Right click the mouse on the file you wish to remove. 

4.   Select Remove From Project. 

Saving Projects 

 To save a project: 
1.   Select Project > Save Project. 

Tip:  You can also save the project by clicking "Save Project As" under the V+ Project menu. Save the 
project in a directory of your choice. 

Closing Projects 

To close a project: 
1.   Select Project > Save Project from the Visual Programming System window. 

2.   Select Yes to save and close the project. 
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WORKSHEETS 

About Worksheets 

A design file in V+ is called a worksheet. Worksheets can be large complete designs or more compact 
designs which are part of a project. Worksheets are individual, working designs independent of other 
worksheets and stored in a project file. They are saved with a .des extension. 

Creating New Worksheets 

Use one of the following methods to start a new worksheet: 

 Select New > File. 

 Select the  button from the toolbar. 

Editing Existing Worksheets (Designs)  

V+ is divided into a development environment, V+ Visual Programming System, and run-time 
environment, V+ Run Time System. Using the development environment,  related design files 
(filename.des) are incorporated into a project file (projectname.vpj). Then, an executable .vne file is 
created allowing the visual program to be executed in the run-time environment.  When a worksheet is 
edited in an existing project, there are a few steps you must follow to successfully make this change part 
of the run-time system and executable file. 

1.   Using the V+ Visual Programming System, open the V+ project (projectname.vpj) containing the 
worksheet. 

2.   Stop the V+ Run Time System, if it's running. 

3.   Using the V+ Visual Programming System, make the necessary changes to your worksheet. 

4.   Select Start from the Platform menu (or select from the shortcut bar) to execute your project. 

5.   After verifying the project is successfully running, select from the shortcut bar to stop the project. 

6.   Save your project and worksheet. Note: Once your project has been successfully executed and 
saved, you must also save the updated executable/platform configuration file. 

7.   Go to the V+ Run Time System window. 

8.   Select Save from the File menu (or select from the shortcut menu) to save the current platform 
configuration (.vne file). 

A Comment on Comments 

You can add text anywhere on a worksheet to make it more readable.  Everyone will appreciate your 
comments when they are using your designs. 
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Adding Comments 

To add comments: 

1.   Select the  button from the toolbar. 

2.   Place the cursor anywhere on the worksheet and double click the mouse. This opens the Edit Text 
dialog box. 

3.   Enter your comments in the dialog box and select the OK button. 

 

Figure 19 - Edit Text Dialog Box 

Editing Comments 

Comment text, font and background properties can be changed at any time. 

To edit text: 
1.   Right click on the text. 

2.   Select Edit from the pop-up menu to open the Edit Text dialog box. 

3.   Edit your text. 

4.   When finished, select the OK button. 

To change the font: 
1.   Right click on the text. 

2.   Select Font from the popup menu to open the Font dialog box. 

3.   Select the desired font and font properties. 

4.   When finished, select the OK button. 

To change the background properties: 
1.   Right click on the text. 

2.   Select Background from the popup menu to open the Worksheet Text Properties dialog box. 

3.   Select the desired background properties. 

4.   When finished, select the OK button. 

Moving Comments 

Comments can be moved anywhere on the worksheet. 
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To move comments: 
 1.   Press the left mouse button on the comment box and drag the comments to the desired location on 

the worksheet. 

Removing Comments 

To remove the comment box: 
1.   Left click the comment to select it. 

2.   Select the  to remove the comment box from the worksheet. 

About Customizing Worksheets 

V+ offers the tools to customize worksheets to suit your needs and match your preferences. The following 
worksheet properties are changed using the Page Layout dialog box. 

 Paper Size 

 Grid 

 Background color 

Setting Page Properties 
The Page Layout dialog box is used to customize the worksheet. The page size and paper color are 
determined and the layout grid is enabled from the Page Layout dialog box. 

To open the Page Layout dialog box: 
1.   Click Design > Page Properties or right-click on the worksheet and choose Properties.  This opens 

the Page Layout dialog box. 

Choosing Paper Size 

The default page layout is "B" size, or 11" X 17." 

To change the paper size: 
1.   Select the applicable radio button. Your selection is displayed in the edit boxes. 

2.   Select OK. 

Tip: Use the Custom radio button to enter paper sizes not listed in the dialog box. 

Enabling the Background Grid 

To enable the background grid: 
1.   Select the Enable Grid check box. 

2.   Select OK. 
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Changing the Background Color 

To select a background color: 
1.   Select the Paper Color button. This opens the Color dialog box. 

2.   Select the background color. 

3.   Select OK. 

TIP: If the color you desire is not listed, click the Define Custom Colors button on the Color dialog 

box. Using the point and click capability of the mouse, select the desired color. Click Add to Custom 

Colors then OK to apply this color to your background. 

Zooming In and Out 

The default worksheet zoom level is set to 100%, or actual size. The zoom is limited from 25% to 225%, 
with 25% increments.  There are a couple of ways to zoom in and out. The first is from the main menu; 
the second is with the zoom tool, found in the worksheet toolbar (see image below). 

Using the Main Menu Using the Zoom Tool 

To zoom in using the main menu: 
1.   From the main menu, select View > Zoom > 

Zoom In. 

To zoom out using the zoom tool: 
1.   From the main menu, select View > Zoom > 

Zoom Out. 

To zoom in using the zoom tool: 
1.   Select the zoom tool from the toolbar. 
2.  Click on the worksheet to zoom in 25%. 
Repeat Step 2. until desired view is reached. 

To zoom out using the zoom tool: 
1.   Select the zoom tool from the toolbar. 
2.  Right-click on the worksheet to zoom out 25%. 
Repeat Step 2. until desired view is reached. 

 

Figure 20 - Zoom Tool 
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OBJECTS 

About Objects 

Objects are the primitives, or the essential programming tools, of the V+ Programming System. Objects 
represent an executable set of instructions which, when connected to other objects or ports, act on 
incoming or preset data.  

When an I/O Device is chosen and configured in the Platform Shell, a list of objects associated with that 
device is made available in the V+ Object View dialog box. The list of objects is constantly growing. 
Ensure that you have the latest release of V+. 

Obsolete Objects 
Object names beginning with (Obsolete) will be removed from the object list, although the objects will still 
load from disk and otherwise operate the same as before.  SimPhonics uses this obsolescence 
mechanism to ensure that these objects are not used for new designs, but still load and may function 
properly.  Be sure to check your objects to ensure that the names do not contain (Obsolete) in the title. 

A warning message will be generated in the development system message window during execution if 
any objects in your design are obsolete.  Warnings do not stop the system from executing, so the system 
will continue to run.  However, the obsolete object may not function properly. The format of the message 
is:  “Warning, obsolete object on (worksheet name): x, y” Where x and y are the worksheet locations.  
This error will be displayed in the development system message window when the design is started.  A 
message will be printed for each object that is found to be obsolete. 

Opening the Objects List 

A list of all available objects is found in the Objects dialog box. 

To open the Objects dialog box: 

1.   Select the  from the project toolbar or select View > Toolbars > Objects. 
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Figure 21 - Objects Dialog Box 

Placing Objects on Worksheets 

To place an object: 

1.   Select the  button or select View > Toolbars > Objects. 

2.   Double-click the object you want to place on the worksheet. 

3.   Place the cursor on the worksheet and click the mouse. The object is now displayed on the worksheet 
with the input and output pins shown. 
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Figure 22 - Placing Objects on Worksheets 

Note: The color of the input/output pins is determined by your system colors. 

Rearranging Objects 

Since V+ is a visual language, it is in your best interest to keep the design as simple as possible. Direct 
routes between objects make the design flow easier to visualize. As you add elements to your design, it 
may be helpful to reorganize the objects or restructure the design. This is easily accomplished using the 
following methods:  

 dragging 

 rotating 

 flipping 

 mirroring 

Dragging Objects 

To drag an object: 

1.   Select the  from the design toolbar. 

2.   Position the arrow over the object. The arrow is properly positioned when a 4 headed arrow appears 
(see below). 

3.   Use the left mouse button and drag the object to its new location. As you drag, a dashed rectangle 
appears around the object. 
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Figure 23 - Dragging Objects 

Note: Moving an object does not affect it connections to other objects or ports. See About Nets for help 
with connections. 

Rotating Objects  

Objects can be rotated counter clockwise in 90 degree increments. 

To rotate an object: 

1.   Select the  from the design toolbar. 

2.   Right click on the object. This opens the object menu box. 

3.   Select Rotate. This rotates the object 90 degrees counter clockwise as shown below. Repeat the 
process to continue rotating the object. 

 

Figure 24 - Rotating Objects 

Note: Rotating an object does not affect its connections to other objects or ports. See About Nets for help 
with connections. 

Flipping Objects  

Objects can be flipped upside down. 

To flip an object: 

1.   Select the  from the design toolbar. 

2.   Right click on the object. This opens the object menu box. 

3.   Select Flip. This flips the object upside down, as shown below. Repeat the process to flip the object 
back to its original position. 
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Figure 25 - Flipping Objects 

Note: Flipping an object does not affect its connections to other objects or ports. See About Nets for help 
with connections. 

Mirroring Objects  

When an object is mirrored, it is flipped horizontally. 

To mirror an object: 

1.   Select the  from the design toolbar. 

2.   Right click on the object. This opens the object menu box. 

3.   Select Mirror. This flips the object horizontally, as shown below. Repeat the process to flip the object 
back to its original position. 

 

Figure 26 - Mirroring Objects 

Note: Mirroring an object does not affect its connections to other objects or ports. See About Nets for 
help with connections. 

Deleting Objects 

To delete an object: 

1.   Select the  button from the design toolbar. 

2.   Click on the object you want to delete. 

3.   Select the  button from the design toolbar or press Delete on the keyboard. 
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Note: When an object is deleted, all its connections are also deleted. 

Getting Help for Objects 

Help is available for each object. See Object Help System for additional information. 

To access Object help: 

1.   Select the  from the project toolbar or select View > Toolbars > Objects. 

2.   Select the object you wish to view help for. 

3.   Select the Object Help button. 

Tip:  Help is also available for objects already placed on the worksheet. Right mouse click over the object 

in question. Choose Description. This opens the help window. 
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STATIC DATA 

About Static Data 

Static Data is data which cannot be altered in any way by the operation performed by the V+ object. This 
data is set in the object itself and can include such information as filenames, channel designations, etc. 
One unique feature of V+ is this data can be changed at any point during run-time by a simple click of the 
mouse without having to reboot the system. This allows the programmer/designer to "tweak" the design 
during the run-time process and, by using monitors, watch how the change affects the outputs. 

Some V+ objects, such as simple mathematical expressions, have no Static Data mechanism since they 
perform operations based only on incoming data.  

TIP: The Object Help System describes static data settings for each object. See Object Help System to 

access this help system. 

Types of Static Data 

The table below gives a list of static data types and a brief description. Use the Object Help System for a 
detailed description of an object’s static data settings.  

Type Description 

Single precision float A constant. This control defaults to a min of 0 and a max of 1.0 

Null terminated text string Anything that needs a string of text in an object to be in static data will 
use this control. A .wav file is an example of this type of static data 

LFI (Linear Function Interpolator) 
Point Generator  

  

Accessing Static Data 

To access static data values: 
1.   Right-click the mouse on the object and select Static Data or double click on the object. 

2.   If there is only one type of static data, the data dialog box opens, skip steps 3-4 and go to Setting 
Static Data. If there is more than one type of static data, the   dialog box opens. 

3.   Select the type of static data you wish to access. 

4.   Select OK. Use the appropriate instructions below to set the data. 
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SETTING STATIC DATA 

 Constants 

 Files 

 LFI Points 

Single precision float - Constant  

The control defaults to a min of 0 and a max of 1.0 

To set static data values: 

1.   Click the  button on the left side of the Constant dialog box and set the value in the Maximum edit 
box to any number greater than one. 

2.   Select OK. 

3.   Once the Min/Max Extents have been set, the actual initial value of the Constant Float object can be 

set. Select the  button. 

4.   Enter the initial value of the Constant Float. 

5.   Select OK. 

 

 

 
 Figure 27 - Setting Static Data 

Note:  When working with constants, the Minimum/Maximum Extents have to be set before the actual 
value of the Constant Float object is set. The Min/Max Extents dialog box determines that the actual value 
will fall between the values entered enabling the slider control you see in the Static Data for the Constant 
Float object 



 

 

V+ Visual Programming System User Manual, V1.15 

Page 41 of 59 
 

SimPhonics, Inc. 

Null terminated text string  

To set static data for null terminated text strings  

1.   Select the  button. 

2.   Browse for and select the appropriate file. 

3.   Select the green Lock button to select the file.   The Filename Box is shown below. 

 

Figure 28 - null terminated text string Static Data 

LFI (Linear Function Interpolator) Point Generator  

To set x, y points on the LFI table: 

1.   Select . 

2.   Use the mouse to drag the point to the desired location on the table. 

 

Figure 29 - LFI Point Generator   

To delete a point: 

1.  Highlight the point and select the  button. 

Note:  Points must be placed at unique x locations. 
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Changing Static Data 

The steps involved in changing static data are the same as setting the data. See Setting Static Data for 
help. 
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NETS 

About Nets 

In V+ terminology, a net is a connection device which links the output pin of an object or port to an input 
pin of another object or port. A net must be started on an output pin and continue to an input pin. A net 
can be routed anywhere on the active worksheet. This is useful for routing nets around objects and other 
obstacles. 

Visually, a net is a small line connecting two pins. Below is an example of a net connecting 2 objects. 

 

Figure 30 - Net 

Connecting Objects with Nets 

Visual objects and ports are connected via "nets". A net connects an object's output pin to one or more 
inputs to another object or port. Nets are drawn, manually on the worksheet using the mouse. Nets must 
start on an output pin and continue to one or more inputs. Nets may be routed around corners, "anchors", 
and do not have to go directly to the destination. Junctions may be added to existing nets in order to add 
another input to the net. 

To link objects: 

1.   Select the  from the design toolbar or select Design > Tools > Net. 

2.   Click on the output pin of the object you are connecting from. 

3.   Click on the input pin that you want to connect to. The two objects are now linked. 

Tip: Nets can be routed around objects by clicking the left mouse button where the net should change 

direction and continuing to the input pin. 

Moving Nets 

Nets can be routed anywhere on the worksheet. This is useful for routing nets around objects or other 
obstacles. 

To move the net: 

1.   Select  from the design toolbar or select Design > Tools > Net. 

2.   Click on and drag the net. A dashed line appears around the angle that is being moved. 
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Figure 31 - Moving Nets 

Deleting Nets 

There are two ways to delete nets: 

 before they are connected to input pins 

 after they are connected to input pins 

To cancel a net before it is connected to an input pin: 
1.   Right click the mouse. 

2.   Select Cancel Net. 

 

Figure 32 - Canceling Nets 

To delete a net after it is connected to an input pin: 

1.   Select  from the design toolbar. 

2.   Click on the net you want to delete.  The net changes to a dashed line. 

 

Figure 33 - Deleting Nets 

3.   Select  from the design toolbar or press Delete on the keyboard. 
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PORTS 

About Ports 

In V+, Ports are the primitive elements of I/O Devices. They connect data from an external device to V+ 
worksheets. After the I/O device has been selected in the Platform Shell, the ports associated with that 
I/O device are loaded into the Port List in the V+ Development System and made available to the user. 
Before an I/O Device is selected and configured, the Port List dialog box remains empty. All ports names 
can be changed from the default name to any name up to 255 characters. Below is a graphical 
representation of V+ ports. 

Normal Input Port Non Available Input Port Non Unique Input Port 

  
An input port which is not 
available due to the I/O device 
not being configured or not 
physically connected. A 
message box will also appear 
indicating this. 

 
An input port that is not unique. 
That is, a port that is already in 
use on that worksheet or on 
other worksheets. A message 
box will also appear indicating 
this. A red port icon in the Port 
List dialog box will also indicate 
this with an "X" in the "in use" 
column. 

Placing Ports on Worksheets 

Ports are placed on worksheets and serve as input and output data mechanisms. To select a port, the 
desired I/O device must first be selected and configured.  See Selecting the I/O Device for more 
information concerning configuring I/O devices. Once the Platform Shell is configured, a list of available 
ports is loaded into the Port List. 

To place a port: 

1.   Select  or select View > Toolbars > Ports. 

2.   Select either the input or the output option from the drop box.  

3.   Double-click the port and drag it to the desired location on the active worksheet and click the port 
again. The port is now displayed on the worksheet. 

 

Figure 34 - Placing Ports 
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Using Connections With Ports 

To use connections, or nets, with input or output ports, follow the same process as you would with any 
other object.  

See Connecting with Nets for more information. 

Moving Ports 

Since V+ is a visual language, it is in your best interest to keep the design as simple as possible. Direct 
routes between objects and ports make the design flow easier to visualize. As you add elements to your 
design, it may be helpful to move ports. This is easily accomplished using the following methods:  

To drag a port: 
1.   Select the arrow tool from the design toolbar. 

2.   Position the arrow over the port. The arrow is properly positioned when a 4 headed arrow appears 
(see below). 

3.   Use the left mouse button and drag the object to its new location. As you drag, a dashed rectangle 
appears around the object (see below). 

 

Figure 35 - Dragging Ports 

Note: Moving a port does not affect its connections to objects. See About Nets for help with connections. 
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EXECUTION 

About Design Execution 

In V+, the initial order that objects are executed is the default order in which they were created. Multiple 
worksheets are executed in the order in which they appear in the Project Manager window. 

Below is a graphic displaying the execution process involved in the V+ Programming System. The input 
ports are extracted from the worksheet(s) and executed first, then the actual objects on the worksheet(s) 
followed by the output ports. 

 

Figure 36 - Execution Sequence 

Tip: V+ programs can be executed from the Visual Editor or the Run-time System. Developers 

should run designs from the Visual Editor while building their program. This makes it easier to monitor 
data and adjust settings. However, once designs are complete, they should be ran from the Run-time 

system. 

Note:  The "GUID" (Globally Unique Identifier) number is used for debugging and programming purposes 
only. 

Executing your V+ Design 

V+ programs can be executed from the Visual Editor or the Run-time System. Developers should run 
designs from the Visual Editor while building programs. This makes it easier to monitor data and adjust 
settings. However, once designs are complete, they should be ran from the Run-time system. 

The Messages Area at the bottom left corner of the Run-time System reflects information regarding the 
status of the design during build and run-time.  

Use either of the following methods to run a design from the V+ Editor: 

 Select  from the platform toolbar  

 Select Platform > Start. 
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Note:  Once a design is executing, the Messages Area informs you that your design is running and a 
green light appears on the V+ Status Bar. Also, a green dashed line appears around all executing objects. 
This is important since during execution of individual designs, only the top-level design will execute. 
However, during execution of a project, all involved designs execute simultaneously. Below are graphics 
showing an object executing and one that is not executing. 

 

Figure 37 - Message Box 

Executing... 

 

Not executing... 

 

Tip:  While the design is running, you may at any time place a monitor on the output pins of any object 

or port to determine the status of data at that point of the design. The data can be manipulated with the 

Static Data controls and the value of the data on the output pins will reflect in real-time through a 
monitor placed on that pin. See Monitoring Real-Time Data for help. 

Changing the Execution Order 

The execution order of objects on a given worksheet is changed using the Execution Order dialog box. In 
the simple example below, the Multiply object was created before the Constant Float object that feeds 
data to both of its inputs. This sets the inputs on the Multiply object to zero on the first execution iteration. 
This can cause serious problems especially in the design of digital filters. 

 

Figure 38 - Multiply and Constant Float Objects 

To set the execution order:  
1.   Select Edit > Execution Order. This opens the Execution Order dialog box. 

2.   Select the object number (see below). 

3.   Use the Up and Down buttons to change the object order. 

4.   Select the OK button. 

 

Figure 39 - Changing Object Execution Order 
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TROUBLESHOOTING 

Editor and Run-time Errors 

When the platform is started from the development system, there are two phases of error checking.  The 
development system checks editor errors, such as unconnected pins, invalid ports, etc.  Once the design 
checks OK, the run-time system is notified that it can begin the run-time startup error checking process.  
This is the runtime error checking phase, 

Run-time Errors 
If a run-time error stops the system, then the message, “Run-time error. See run-time message window” 
appears, in the development system message window. To review error details, go to the Run-time system 
message window. 

Note: If the user stops the system, the message, “User stopped system.” Appears in both the run-time 

and development system windows. 

Editor Errors 
If an object/port is causing an error, message provides the worksheet name, object name and X-Y 
coordinates. This feature is useful when working on large projects with multiple worksheets. 

Log Files 
 
The V+ Development System and V+ Run-time System can both generate text based ASCII log files 
collect information as the software is running. Logging is a feature that is available in V+ Build 362 and 
greater. The run-time system is where most of the log information would be useful since that is where V+ 
executes designs, user configuration occurs, etc. The Development and runtime log filenames are fixed 
with the following names: 
 
Development System: V+DevLog.txt 

Run time System: V+RuntimeLog.txt 

 
The logging activity can be turned on or off via keys in the system registry. The locations are as follows. If 
the key is set to nonzero then logging will occur, otherwise it will be turned off.  
 

Development system: 
HKEY_LOCAL_MACHINE\SOFTWARE\SimPhonics\VPLus\ 

DWORD “enableLogFile”  

 
Runtime system: 
HKEY_LOCAL_MACHINE\SOFTWARE\SimPhonics\VPLus\Platforms\Native Platform\ 

DWORD “enableLogFile”  

 
The files will be located in the folder where V+ lives. This is normally C:\Program Files\VPLus\. 

The file format for these log files are divided into two areas. The first area is initial information about the 
hardware and software of the computer and is the first section of the log file. The second area following 
the first is the actual log messages that are collected over time. Each message is numbered and time 
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stamped with an accurate time based on the CPU clock time.  For example a typical log entry for the run 
time system is shown below. The font and font color has been changed for easy readability. 
 

1 [2009-10-14] 14:11:17.490:  Output Device 1 Found: -- IDT Audio1 
 

The color coded text is defined as follows: 
 
Black  Line Number  
Red  Date: Year, Month, Day 
Green  Time Stamp in 24 hour format: Hour, Minute, Second, millisecond 
Blue  Actual message 
 

All files start at the second character position and continue to the end of the line without any line breaks.  
There are no extra lines between message lines. Each log file will continue to gather messages until the 
software is closed regardless of the status of the run/stopped state. The files are not buffered and as 
soon as a message is generated, it goes directly to the disk and bypasses any buffering that the 
operating system may provide.  
 
All information is flushed to the log file when V+ is started and stopped. 
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Ethernet Connections to/from V+ 

The following Ethernet configuration data is presented to help choose ports for various Ethernet 
interfaces in V+.  
 

Interface Port(s) Protocol 

V+ Remote Control 5067 – Transmit Port 
5068 – Listen Port 
 
Controlled via registry variables at: 
 
HKEY_LOCAL_MACHINE\SimPhonics\Software\VPLus\ 
RemoteControlListenPort 
RemoteControlTransmitPort 

TCP/IP 

Custom Socket I/O Device 5050 – Listen Port 
Auto – Transmit Port 
 
User Programmable via GUI 

UDP/IP 

UDP/IP I/O Device 5070 – Transmit Port 
5071 – Listen Port 
 
User Programmable via GUI 

UDP/IP 

Flash I/O Device 4345 – Listen Port 
Auto – Transmit Port 
 
This is currently hard coded. 

TCP/IP 

VComm DIS 3000 – Transmit Port 
 
User Programmable via GUI 

UDP/IP 
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Figure 40 - Locating Errors 

System Crashes 

Possible Cause Solution 
Obsolete Object Inspect your worksheet, and verify that the title of any of your objects do not start with  the 

word “(obsolete).”  
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REAL-TIME DATA 

About Real-Time Data 

Any data that changes meaningfully with respect to time is referred to as time-based media, or real-time 
data. Real-time in operating systems is the ability of the operating system to provide a required level of 
data in a bounded response time. Audio clips are common forms of time-based media. Such media data 
can be obtained from a variety of sources, such as local or network files.  

Monitoring Real-Time Data 

Monitors allow the user to see the value of data within a V+ design during run-time. This gives V+ a 
distinct advantage over text-based programming languages in that the user can "tune" the design during 
real-time without having to change a line of code. A monitor is a box showing the data value of a 
particular pin at a given time during the execution of a design.  

To monitor data: 
1.   Right click on the output pin of any object or port during run-time.  

2.   Select Monitor. A gray box appears showing the value of the data at that point (see below).  Below is 
an example of a monitor placed on the output pin of the square root object with an input value of "16." 

 

Figure 41 - Monitoring Real-time Data 

Tip: To change the value of the data, adjust the Static Data control that inputs data to that pin. See 
Changing Static Data for help. 

To close the monitor box: 
1.   Right click on the monitor box.  

2.   Select Close to close the monitor box. 

 

Figure 42 - Closing the Monitor Box 
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APPENDIX A - GLOSSARY 

connections 
In V+, these are called Nets, and they link output pins of an object to one or more input pins of another 
object or port. Nets appear as a line between two pins and can be routed around obstacles at the user's 
discretion. 

design 
A worksheet drawing(s) created in the V+ Development System. Designs are visual programs analogous 
to programs designed in a text-based programming system. A design may consist of one or more 
worksheets. 

development system 
Used to create and edit designs. Also called a visual editor. 

I/O devices 
Input and output mechanisms used to transfer real-world data into or out of a V+ design. I/O devices 
contain one or more ports that represent each element of an I/O device. 

monitor 
A box showing the data value of a particular pin at a given time during design execution. 

nets 
Connections that link output pins of an object to one or more input pins of another object or port. Nets 
appear as a line between two pins and can be routed around obstacles at the user's discretion. 

non-native platforms 
A non-native platform is a platform that is not the same as the development platform. All non-native 
platforms are external to the development machine. The ablility to interface with external platforms is one 
of the most important features of the V+ Visual Programming System. 

objects 
Visual primitives, or the essential programming tools, in V+. They represent an executable set of 
instructions which, when connected to other objects or ports, act on incoming or preset data. 

pins 
Input or output connections on objects. They are shown visually on the worksheet as small lines 
extending from objects. Pins allow objects to be interconnected via nets, and represent data that is either 
flowing into or out of an object. 

platform 
The execution environment for V+ designs. Platforms communicate via I/O devices allowing the user to 
visually generate multi-processing applications. 

platform shell 
Also called the run-time system. Used to configure the system and execute the designs created in the 
editor. 

ports 
The fundamental input and output data mechanism of V+, representing primitive data types such as a 
single bit, byte, word, float, etc. 

Project 
In V+, a project is a collection of files, or designs, which toqether make up a complete visual design. 

project manager 
Used to view and maintain files contained in a project. 

real-time data 
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Any data that changes meaningfully with respect to time is referred to as time-based media, or real-time 
data. Real-time in operating systems is the ability of the operating system to provide a required level of 
data in a bounded response time. Audio clips are common forms of time-based media. Such media data 
can be obtained from a variety of sources, such as local or network files. 

run-time system 
Used to configure the system and to execute designs created in the editor. Also called the platform shell 

spare time 
Designs take a finite amount of time each frame. The spare time is the amount of time left in each period 
(frame). So, for example if the V+ design required 12.5ms to execute, and the user had selected a 25ms 
frame rate the spare time should be 50%. 

static data 
Data which cannot be altered in any way by the operation performed by the V+ object. This data is set in 
the object itself and can include such information as filenames, channel designations, etc. 

V+ editor 
The visual editor. See "development system." 

visual editor 
The development system, used to create and edit designs. 

worksheet 
In V+, a worksheet is a file, represented by a single window, that contains the user design. One or more 
worksheets together form the complete user design. 
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